$re = '`^(?:((?:January|February|March|April|May|June|July|August|September|October|November|December) \d+ at \d+:\d+[ap]m)|(Yesterday at \d+:\d+[ap]m)|(\d+ hours ago)|(About an hour ago)) \D*?(\d+)?$`m';
$str = 'September 5 at 8:40pm · Like · 23
Yesterday at 5:35am · Like
10 hours ago · Like · 2
6 hours ago · Like';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);