re = /^(?:((?:January|February|March|April|May|June|July|August|September|October|November|December) \d+ at \d+:\d+[ap]m)|(Yesterday at \d+:\d+[ap]m)|(\d+ hours ago)|(About an hour ago)) \D*?(\d+)?$/m
str = 'September 5 at 8:40pm · Like · 23
Yesterday at 5:35am · Like
10 hours ago · Like · 2
6 hours ago · Like'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end