const regex = new RegExp('^(?:((?:January|February|March|April|May|June|July|August|September|October|November|December) \\d+ at \\d+:\\d+[ap]m)|(Yesterday at \\d+:\\d+[ap]m)|(\\d+ hours ago)|(About an hour ago)) \\D*?(\\d+)?$', 'gm')
const str = `September 5 at 8:40pm · Like · 23
Yesterday at 5:35am · Like
10 hours ago · Like · 2
6 hours ago · Like`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}