#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Start.*$"
Local $sString = "87, 72 Start I am a sentence finish"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)