use strict;
my $str = '87, 72 Start I am a sentence finish';
my $regex = qr/Start.*$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";