# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\bnone\b|\d+(?:\.\d+)?)%?/\1|/gi;t' <<< "0.100% fDrg: 2%,dgdv: 29% fGd dg 0.2%, Ghh-sf 2.2 dbgh: NONE dfgdf6 gd 3 "