import re
regex = re.compile(r"(\bnone\b|\d+(?:\.\d+)?)%?", flags=re.IGNORECASE)
test_str = "0.100% fDrg: 2%,dgdv: 29% fGd dg 0.2%, Ghh-sf 2.2 dbgh: NONE dfgdf6 gd 3 "
subst = "\\1|"
result = regex.sub(subst, test_str)
if result:
print(result)