const regex = new RegExp('(\\bnone\\b|\\d+(?:\\.\\d+)?)%?', 'gi')
const str = `0.100% fDrg: 2%,dgdv: 29% fGd dg 0.2%, Ghh-sf 2.2 dbgh: NONE dfgdf6 gd 3 `;
const subst = `\1|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);