re = /(\bnone\b|\d+(?:\.\d+)?)%?/i
str = '0.100% fDrg: 2%,dgdv: 29% fGd dg 0.2%, Ghh-sf 2.2 dbgh: NONE dfgdf6 gd 3 '
subst = '\\1|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result