using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\p{L}0-9\s\-]+$";
string input = @"Kho hàng 1 - SaComPay
Kho hàng 2 - BaoBao
amisapp.misa.vn
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}