package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{L}0-9\s\-]+$`)
var str = `Kho hàng 1 - SaComPay
Kho hàng 2 - BaoBao
amisapp.misa.vn
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}