const regex = new RegExp('^[\\p{L}0-9\\s\\-]+$', 'gm')
const str = `Kho hàng 1 - SaComPay
Kho hàng 2 - BaoBao
amisapp.misa.vn
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}