re = /^[\p{L}0-9\s\-]+$/m
str = 'Kho hàng 1 - SaComPay
Kho hàng 2 - BaoBao
amisapp.misa.vn
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end