#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http://images\.(\d+)_120\*75)(?![\s\S]*\1)"
Local $sString = "http://images.123456_120*75" & @CRLF & _
"http://images.123456_120*75" & @CRLF & _
"http://images.784217_120*75" & @CRLF & _
"http://images.784217_120*75" & @CRLF & _
"http://images.123456_120*75" & @CRLF & _
"http://images.123456_120*75" & @CRLF & _
"http://images.784217_120*75" & @CRLF & _
"http://images.784217_120*75" & @CRLF & _
"http://images.123456_120*75" & @CRLF & _
"http://images.123456_120*75" & @CRLF & _
"http://images.784217_120*75" & @CRLF & _
"http://images.784217_120*75"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")