re = /(http:\/\/images\.(\d+)_120\*75)(?![\s\S]*\1)/m
str = 'http://images.123456_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.123456_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.123456_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end