using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http://images\.(\d+)_120\*75)(?![\s\S]*\1)";
string input = @"http://images.123456_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.123456_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75
http://images.123456_120*75
http://images.123456_120*75
http://images.784217_120*75
http://images.784217_120*75";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}