// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*").unwrap();
let string = "Name Surname
Name Surname
Name Surname
Name Surname
Name Surname
Name Surname
Name Surname";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}