# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^;]*(\((?>[^()]+|(?1))*\))(*SKIP)(*F)|;/,/gm;t' <<< "Almonds ; Roasted Peanuts (Peanuts; Canola Oil (Antioxidants (319; 320)); Salt); Cashews
Peanuts (32.5%); Macadamia Nuts (14%; PPPG(AHA)); Hazelnuts (9%); nuts(98%)"