const regex = /[^;]*(\((?>[^()]+|(?1))*\))(*SKIP)(*F)|;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^;]*(\\((?>[^()]+|(?1))*\\))(*SKIP)(*F)|;', 'gm')
const str = `Almonds ; Roasted Peanuts (Peanuts; Canola Oil (Antioxidants (319; 320)); Salt); Cashews
Peanuts (32.5%); Macadamia Nuts (14%; PPPG(AHA)); Hazelnuts (9%); nuts(98%)`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);