import re
regex = re.compile(r"[^;]*(\((?>[^()]+|(?1))*\))(*SKIP)(*F)|;", flags=re.MULTILINE)
test_str = ("Almonds ; Roasted Peanuts (Peanuts; Canola Oil (Antioxidants (319; 320)); Salt); Cashews \n"
"Peanuts (32.5%); Macadamia Nuts (14%; PPPG(AHA)); Hazelnuts (9%); nuts(98%)")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)