re = /[^;]*(\((?>[^()]+|(?1))*\))(*SKIP)(*F)|;/m
str = 'Almonds ; Roasted Peanuts (Peanuts; Canola Oil (Antioxidants (319; 320)); Salt); Cashews
Peanuts (32.5%); Macadamia Nuts (14%; PPPG(AHA)); Hazelnuts (9%); nuts(98%)'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result