using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<key>\w+)=\[(?P<values>(\w+\d;?)+)\]";
string input = @"title=[a3;d2;g5;a5] #comment
# other comment
some_key=[j7;k9]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}