re = /(?P<key>\w+)=\[(?P<values>(\w+\d;?)+)\]/
str = 'title=[a3;d2;g5;a5] #comment
# other comment
some_key=[j7;k9]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end