import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<key>\\w+)=\\[(?P<values>(\\w+\\d;?)+)\\]";
final String string = "title=[a3;d2;g5;a5] #comment\n"
+ "# other comment\n"
+ "some_key=[j7;k9]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}