const regex = new RegExp('(?P<key>\\w+)=\\[(?P<values>(\\w+\\d;?)+)\\]', 'g')
const str = `title=[a3;d2;g5;a5] #comment
# other comment
some_key=[j7;k9]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}