using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(.*)-";
string input = @"num-12345678-num
num-12345678-234-213-num
X-8551-03-24-13.20.29.709622-Z";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}