import re
regex = re.compile(r"-(.*)-")
test_str = ("num-12345678-num \n"
" num-12345678-234-213-num\n"
"X-8551-03-24-13.20.29.709622-Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")