package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-(.*)-`)
var str = `num-12345678-num
num-12345678-234-213-num
X-8551-03-24-13.20.29.709622-Z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}