// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-(.*)-").unwrap();
let string = "num-12345678-num
num-12345678-234-213-num
X-8551-03-24-13.20.29.709622-Z";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}