package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}`)
var str = `0127,Central WM
0128,Central WM
0129,Central WM
0130,Central WM
089I,Inbound EWM
089O,Outbound EWM
089P,PSA in EWM
9988,Packstücke WM
CM01,CM01 in 1000
CM02,CM02 in 1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}