import re
regex = re.compile(r"^\d{4}", flags=re.MULTILINE)
test_str = ("0127,Central WM\n"
"0128,Central WM\n"
"0129,Central WM\n"
"0130,Central WM\n"
"089I,Inbound EWM\n"
"089O,Outbound EWM\n"
"089P,PSA in EWM\n"
"9988,Packstücke WM\n"
"CM01,CM01 in 1000\n"
"CM02,CM02 in 1000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")