const regex = /^\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4}', 'gm')
const str = `0127,Central WM
0128,Central WM
0129,Central WM
0130,Central WM
089I,Inbound EWM
089O,Outbound EWM
089P,PSA in EWM
9988,Packstücke WM
CM01,CM01 in 1000
CM02,CM02 in 1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}