use strict;
my $str = 'function void test ( ) {
if ( false ) {
let s = "constant one two" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
} ';
my $regex = qr/\s(?=([^"]|"[^"]*")*$)/p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";