$re = '/\s(?=([^"]|"[^"]*")*$)/';
$str = 'function void test ( ) {
if ( false ) {
let s = "constant one two" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
} ';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;