import Foundation
let pattern = #"\s(?=([^"]|"[^"]*")*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
function void test ( ) {
if ( false ) {
let s = "constant one two" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)