re = /\s(?=([^"]|"[^"]*")*$)/
str = 'function void test ( ) {
if ( false ) {
let s = "constant one two" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
} '
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result