# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"]*"(*SKIP)(*F)|\s/_/g;t' <<< "function void test ( ) {
if ( false ) {
let s = \"constant one two\" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
} "