using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""(*SKIP)(*F)|\s";
string substitution = @"_";
string input = @"function void test ( ) {
if ( false ) {
let s = ""constant one two"" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
} ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}