#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""[^"]*"(*SKIP)(*F)|\s"
Local $sString = "function void test ( ) { " & @CRLF & _
" if ( false ) { " & @CRLF & _
" let s = "constant one two" ; " & @CRLF & _
" let s = null ; " & @CRLF & _
" let a [ 1 ] = a [ 2 ] ; " & @CRLF & _
" } " & @CRLF & _
" } "
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)