package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]*"(*SKIP)(*F)|\s`)
var str = `function void test ( ) {
if ( false ) {
let s = "constant one two" ;
let s = null ;
let a [ 1 ] = a [ 2 ] ;
}
} `
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}