using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\D)\d";
string substitution = @"";
string input = @"number1234567890";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}