use strict;
my $str = 'number1234567890';
my $regex = qr/(?<=\D)\d/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";