$re = '/(?<=\D)\d/';
$str = 'number1234567890';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;