import re
regex = re.compile(r"(?<=\D)\d")
test_str = "number1234567890"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)