import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<a_only>^a)|(?:a:)(?P<a_colon>[^\\/].+)|(?P<a_slash>a\\/\\d{1,2})";
final String string = "a\n"
+ "a:example.com\n"
+ "a:mailers.example.com\n"
+ "a/24\n"
+ "a:offsite.example.com/24";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}