$re = '/(?P<a_only>^a)|(?:a:)(?P<a_colon>[^\/].+)|(?P<a_slash>a\/\d{1,2})/i';
$str = 'a
a:example.com
a:mailers.example.com
a/24
a:offsite.example.com/24';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);