re = /(?P<a_only>^a)|(?:a:)(?P<a_colon>[^\/].+)|(?P<a_slash>a\/\d{1,2})/i
str = 'a
a:example.com
a:mailers.example.com
a/24
a:offsite.example.com/24'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end