const regex = /(?P<a_only>^a)|(?:a:)(?P<a_colon>[^\/].+)|(?P<a_slash>a\/\d{1,2})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<a_only>^a)|(?:a:)(?P<a_colon>[^\\\/].+)|(?P<a_slash>a\\\/\\d{1,2})', 'gi')
const str = `a
a:example.com
a:mailers.example.com
a/24
a:offsite.example.com/24`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}