#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Let's start(.*[\r\n])*.*my friend\."
Local $sString = "How much wood? Who knew! Let's start! ... blah, blah, blah..." & @CRLF & _
"How much " & @CRLF & _
"" & @CRLF & _
"longer? It's joe's place*, isn't it?" & @CRLF & _
"This is! [the end], my friend. Ok, Let's do some more testing."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")