import re
regex = re.compile(r"Let's start(.*[\r\n])*.*my friend\.", flags=re.MULTILINE)
test_str = ("How much wood? Who knew! Let's start! ... blah, blah, blah...\n"
"How much \n\n"
"longer? It's joe's place*, isn't it?\n"
"This is! [the end], my friend. Ok, Let's do some more testing.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")